Range Dinâmico

Olá pessoal.

Hoje vou falar sobre um assunto que é bem interessante, principalmente quando trabalhamos com dados em planilhas do Excel.

Diversas vezes para fazer uma simples SOMA utilizamos um intervalo estático, exemplo, A1:A10, mas e se quisessemos que ao incluir um item nesta lista não precisassemos alterar o intervalo da função SOMA?

Ai é que entra o range dinâmico, que irá alterar o tamanho do intervalo de acordo com a quantidade de itens.

Para isso teremos que em primeiro lugar criar um nome, utilizando as teclas CTRL + F3 ou utilizando a faixa de opções “Formulas -> Gerenciador de Nomes”

Criaremos um nome chamado RD_SOMA (Range Dinâmico Soma), para isso clicar no botão NOVO e no campo nome escrever o RD_SOMA e clicar em OK.

Agora que vem a “mágica”, no formulário que ficou aberto clicar no nome que vc acabou de criar e lá embaixo no campo “Refere-se a:” iremos digitar a seguinte formula:

=DESLOC(Plan1!$A$1;0;0;CONT.VALORES(Plan1!A:A);1)

Como podemos observar utilizamos a função DESLOC que nada mais faz do que deslocar um intervalo para outro lugar. Agora podemos usar a função soma desta maneira =SOMA(RD_SOMA) que não importa quantos itens teremos na coluna A que sempre irá aumentar dinamicamente o intervalo deste nome. Este foi um exemplo simples sobre o uso do range dinâmico, mas o mesmo pode ser utilizado em tabelas dinâmicas, lista de validações e outras diversas funções no Excel que utilizem intervalos.

Veja também

2017-10-10T12:10:47-03:00